FREE STANDARD SHIPPING ON ALL ORDERS | FREE SIZING

FAQs

Q: How do I determine which firmware is in my Proximity watch?
A:

Firmware identification may be determined by markings by the serial number of your and and through the Proximity Ap v 1.1.9 or higher. Click here to view the firmware identification guide.

Q: Can I use Proximity App v1.x and v2.5 at the same time?
A:

Running different versions of the Proximity App concurrently will cause the your Proximity watch to not properly communicate with your iPhone. It is important to only install and use the proper app for your firmware version.

If your Proximity watch features firmware v1.0, 1.1 or 2.0, you will need to use App v1.2 to unlock Bluetooth functionality.

If you are self-updating your firmware v2.0 to v2.5, be sure to delete App v1.2 first. Then download App v2.5 and update from within App v2.5. Click here for a firmware update guide.

If your Proximity watch features firmware v2.5, you must use only Proximity App v2.5 or higher.

 

Q: Selecting correct Proximity model
A:

Proximity movements come in two different calibers, W760 and W770. Please make sure to read the watch case back to find the correct caliber number before making a selection.

Please refer to the following pictures for caliber number location.

Prox Caliber Caseback

Q: Is the Proximity watch compatible with iOS 8?
A:

Your Proximity watch is compatible with iOS 8 provided your Proximity watch features firmware 2.5 or higher. You must also use Proximity App v2.5 available for free from the iTunes store.

If your watch has a small ‘dot’ mark after the serial number, you may have firmware v2.0 or firmware v2.5 in your watch. Your exact firmware version may be determined after a bluetooth connection with app v2.0 or v2.5 running.

If you are using the Proximity watch with firmware v2.0, you may self upgrade to firmware v2.5 through Proximity App v2.5.

If your Proximity watch does not feature a small punch mark after the serial number, please contact your nearest Authorized Service Center for information on upgrading your firmware.

If you are located in the United States please contact our Customer Care team at:
800 321 1023 ext 4234 between the hours of 7:00 am to 3:45 pm, Pacific Time Monday through Friday  or, email us at:  customerservice_us@citizenwatch.com

If you are located in Canada, please contact our Customer Care Team at:
800 461 4189 between the hours of 8:30 am to 3:45 pm, Eastern Time Monday through Friday  or, email us at: customerservice_ca@citizenwatch.com

If you are located in the United Kingdom, please contact our Customer Care Team at:
0118 936 8855 between the hours of 9.00 am to 5.00 pm, Monday through Friday
or, email us at: service@citizenwatch.co.uk

If you are located in another country, please visit:

http://www.citizenwatch-global.com/network/index.html

to discover a Support Team near you

Q: Proximity Firmware
A:

If your Proximity watch has not been updated by Citizen to at least v2.0,  or was not purchased with firmware v2.0, Citizen will need to physically update your watch. This updating of your Proximity is at no charge to you.

Referring to the serial number of your watch, if there is a small punch mark or laser engraved dot AFTER the serial number, your watch features firmware v2.0 (Click here for ID  guide).  If you have Proximity App v1.1.9 or later installed and have an active Bluetooth connection with your Proximity watch, you may view your firmware version at the bottom of the main screen.

Firmware Version 2.0 – iPhones with iOS5 and iOS6 –  this enhances compatibility with iPhones running iOS 5.1 through iOS 6.4.  Additionally, this provides the base for firmware updating through the Bluetooth connection and Proximity App when or if  you upgrade your iPhone to iOS7 or iOS 8. This is compatible with Proximity App V1.0 – 2.0 (white icon) . It is not compatible with App v2.5 (Blue icon)

Firmware Version 2.5- iPhones with iOS 7,  iOS 8 or iOS9 only -  If Citizen has upgraded your firmware to v2.0 or your purchased your watch with firmware version 2.0,  and are using iOS7 or iOS 8, you can self-update through Proximity App v2.5 (Blue icon) currently available on the iTunes App store.  Firmware v2.5 is not backwards compatible with iOS5 or iOS6.

If you are located in the United States please contact our Customer Care team at:
800 321 1023 ext 4234 between the hours of 7:00 am to 3:45 pm, Pacific Time Monday through Friday  or, email us at:  customerservice_us@citizenwatch.com

If you are located in Canada, please contact our Customer Care Team at:
800 461 4189 between the hours of 8:30 am to 3:45 pm, Eastern Time Monday through Friday  or, email us at: customerservice_ca@citizenwatch.com

If you are located in the United Kingdom, please contact our Customer Care Team at:
0118 936 8855 between the hours of 9.00 am to 5.00 pm, Monday through Friday
or, email us at: service@citizenwatch.co.uk

If you are located in another country, please visit:

http://www.citizenwatch-global.com/network/index.html

to discover a Support Team near you

Q: Which iPhone® is compatible with the Proximity Watch and App?
A:

The Proximity watch featuring firmware 1.0 or 1.1 and Proximity App v1.0 to 2.0 with the following iPhones on iOS 5 or iOS 6:

iPhone® 4S
iPhone® 5

The Proximity watch featuring firmware v2.0 and Proximity App v2.0 with the following iPhones on iOS 5,  iOS 6 or iOS 7:

iPhone® 4S
iPhone® 5
iPhone® 5C
iPhone® 5S

The Proximity watch featuring firmware v2.5 and Proximity App v2.5. with the following iPhones on iOS 7,  iOS 8 or iOS9

iPhone® 4S
iPhone® 5
iPhone® 5C
iPhone® 5S
iPhone® 6 or 6 Plus
iPhone® 6S or 6S Plus

 

 

Q: Where do I get the Proximity App for my compatible iPhone®?
A:

There are two free of charge Proximity Apps available from the Apple® App Store on your compatible iPhone® or from iTunes on your computer.  Search for “Citizen Eco-Drive Proximity”.

Be sure to use only the app appropriate for your Proximity Watch Firmware.  Click here for a guide to discover your Proximity watch firmware.

If you are using iOS5 or iOS6 and your Proximity watches featuring firmware 1.0, 1.1 or 2.0,  Click here to go to the iTunes preview web page for the Citizen Eco-Drive Proximity App v1.2.0.

If you are using iOS7 (7.0.4 or higher),  iOS 8 or iOS9 and your Proximity watches featuring firmware 2.0 or 2.5, Click here to go to the iTunes preview web page for the Citizen Eco-Drive Proximity App v2.5.

Q: Is there a guide for updating my Proximity Firmware from v2.0 to v2.5?
A:

Click here to view and/or download a guide for firmware self-updating. Please note, your Proximity watch must feature firmware v2.0 or higher to self-update your firmware. If your Proximity watch does not feature firmware v2.0 or higher, you will not be able to self=update your firmware. Click here for a guide to checking your firmware version.

Q: Why does My Proximity watch only get link loss notifications, but not email, messages, etc?
A:

Typically this is an indication that multiple devices and related apps are using the iOS notification systems are active at the same time.  One such example is the Fitbit device and related app with Bluetooth syncing active.

In cases such as this, you will need to disable the Bluetooth syncing of the Fitbit device in order for your Proximity watch to properly communicate with the notification system in iOS.

This is a limitation of iOS and multiple devices leveraging the iOS notification systems

Q: Is my Proximity watch compatible with iOS9?
A:

Your Proximity watch is compatible with iOS 9 provided your Proximity watch features firmware 2.5 or higher. You must also use Proximity App v2.5 available for free from the iTunes store.

If your watch has a small ‘dot’ mark after the serial number, you may have firmware v2.0 or firmware v2.5 in your watch. Your exact firmware version may be determined after a bluetooth connection with app v2.0 or v2.5 running.

If you are using the Proximity watch with firmware v2.0, you may self upgrade to firmware v2.5 through Proximity App v2.5.

If your Proximity watch does not feature a small punch mark after the serial number, please contact your nearest Authorized Service Center for information on upgrading your firmware.

If you are located in the United States please contact our Customer Care team at:
800 321 1023 ext 4234 between the hours of 7:00 am to 3:45 pm, Pacific Time Monday through Friday  or, email us at:  customerservice_us@citizenwatch.com

If you are located in Canada, please contact our Customer Care Team at:
800 461 4189 between the hours of 8:30 am to 3:45 pm, Eastern Time Monday through Friday  or, email us at: customerservice_ca@citizenwatch.com

If you are located in the United Kingdom, please contact our Customer Care Team at:
0118 936 8855 between the hours of 9.00 am to 5.00 pm, Monday through Friday
or, email us at: service@citizenwatch.co.uk

If you are located in another country, please visit:

http://www.citizenwatch-global.com/network/index.html

to discover a Support Team near you

Q: Is there a user guide for Proximity App v2.5?
A:

Click here to view/download a guide

Q: Is there an Android Version for Proximity available?
A:

The Proximity Watch and App are compatible with the iPhone® 4S and higher only.   We are not aware of any development of an Android compatible version of the Proximity Watch and App as of November 2012.

Q: Is there a comprehensive FAQ list for Proximity?
A:

Click Here to download the most current FAQ list. This may be viewed on-line, saved to your computer and/or printed. Requires a PDF enabled reader such as Adobe Acrobat Reader.

Q: I am trying to set up my iCloud email account through the “other” option, but keep getting a message “cannot get mail. user name or password cannot be verified”. I have verified the information I am entering is correct. What am I doing wrong?
A:

When setting up an iCloud account in the Proximity App, be sure you enter only the part of your email preceding the @icloud.com. As an example for an email such as “myicloudaccount@icloud.com”, the correct entries would be:

User Name = myicloudaccount
Password = your secret password
Description – any description you choose

IMAP Server = imap.mail.me.com
Server Port = 993

If your iCloud account ends in “me.com”, such as myicloudaccount@me.com, you would include the @me.com. Example:

User Name = myicloudaccount@me.com
Password = your secret password
Description – any description you choose

IMAP Server = imap.mail.me.com
Server Port = 993

Q: I have Proximity firmware v2.0 and am trying to self-update to firmware v2.5 but get a message to contact Citizen. Why?
A:

Typically, this occurs when there is an active Bluetooth connection between your Proximity watch and iPhone through App v1.x.

When self-updating from firmware v2.0 to v2.5, be sure to delete Proximity App v1.x as well as anyProximity Bluetooth device(s) on your iPhone before using Proximity App v2.5 to update your firmware.  Click here for a firmware guide on self-updating your firmware from v2.0 to v2.5

Citizen Eco-Drive news and announcements delivered right to your inbox.

Sign up below
* indicates required